Go Back   6th Gen Accord DIY and Performance Forums

Register to remove these ads


6th Gen Accord DIY and Performance Forums

6th Gen Accord DIY and Performance Forums (http://www.6thgenaccord.com/forums/index.php)
-   URGENT - Help Quick! (http://www.6thgenaccord.com/forums/forumdisplay.php?f=41)
-   -   Washed engine bay, now all dash lights on (http://www.6thgenaccord.com/forums/showthread.php?t=53069)

Ham Solo 06-10-2017 10:17 AM

Washed engine bay, now all dash lights on
 
Hey everyone,
I tried searching for my problem, but have come up empty handed. Last weekend I washed my engine bay using the Gunk engine degreaser and just a normal hose and sprayer head. I know I should've been more careful, but I did it when I first got the car and had no issues. I didn't cover anything just sprayed the degreaser everywhere and then rinsed everywhere. Now my problem is every dash light is on. Battery, doors open, brake bulb out, e-brake on. I'm not sure what happened. Hoping someone knows where to start looking. I tried to dry out the fuse box and let it sit for a week. I disconnected the battery for an hour and it's still doing it. Any ideas? Thank you!

Szaaryy 06-10-2017 01:07 PM

Re: Washed engine bay, now all dash lights on
 
I'm not a mechanic, but i think that water get in to the computer. Is everything working properly?

Wysłane z mojego SM-G900F przy użyciu Tapatalka

dawg316 06-10-2017 02:09 PM

Re: Washed engine bay, now all dash lights on
 
computers on the inside so your fine.

do you have acsess to a volt meter. start the car and run it. check battery voltage at the batery when running. is it about 12.6 volts when running ?


for nect time its good practice to take plastic bags and cover every connector and fuse box. i also cover the alternator aswell

Ham Solo 06-11-2017 03:33 PM

Re: Washed engine bay, now all dash lights on
 
Well I messed with it more today. I tried to drive it to see if there were any other issues. At first my radio (aftermarket) kept cutting in and out. Then the odometer on my dash died and so did the speedometer. I tried to accelerate but the car kept stumbling, kind of felt like my abs might have been kicking on. I could barely go over 5 mph. My car is manual so I just let it coast in neutral back to my parking spot. I went to my local pick n pull and grabbed a couple multiplex control units to see if by some chance that is it. I could only get an auto coupe, and a manual sedan so hopefully it won't cause issues. Any other ideas of what it could be now?

Sent from my SM-G935V using Tapatalk

dawg316 06-11-2017 05:21 PM

Re: Washed engine bay, now all dash lights on
 
try firing parts at in blindley. that should work.

Nam1911a1 06-11-2017 06:03 PM

Re: Washed engine bay, now all dash lights on
 
Never heard of this happening. Hondas must not be as weather resistant as toyotas. My 95 Camry had no hood for about 6 months. I drove through the rainy season, through thunderstorms with hours of showers all day and night. That car would start up and run like a champ. That was the time I had one of the most ghetto rides in town lol. I was poor and a new hood and installation cost me 450

Rusty Accord 06-12-2017 01:49 AM

Re: Washed engine bay, now all dash lights on
 
I've got a 92 Geo Prizm like that. It's a tank on wheels, and I use it on the farm for pulling other cars out/around from different parking spaces. It's basically a Corolla under the sheet metal. My biggest issue with it is rust, so it'll keep it's winter job as a daily salt sucker. ;)

But I've heard of other people having problems with getting the under hood area wet. My dad had that happen to an S-10 before, and I've heard of others with Honda's having electrical problems too (after washing the engine). It makes me wonder what Toyota did that Honda didn't that allows them to run when wet. I mean they both use Denso parts.

DarkSideAccord 06-12-2017 11:59 AM

Re: Washed engine bay, now all dash lights on
 
did u cover the alternator, distributor, battery and fuse box when u washed the engine bay?? sounds like shorted something

SupraGuy 06-12-2017 01:04 PM

Re: Washed engine bay, now all dash lights on
 
All dash lights on is usually indicative of alternator failure.

This is by design. Washing the engine bay can cause the diode trio or voltage regulator in the alternator to crap out if you get some crap in there. (Usually it will do no harm at all, but I've had it happen.) I've also seen the "all dash lights on" for alternator failure on several different makes and models.

A voltmeter is helpful in diagnosing this, but I'd get your alternator tested at the very least.

Connie 06-14-2017 10:38 AM

Re: Washed engine bay, now all dash lights on
 
I have a similar dash light issue that started over the last 10k km, but doesn't affect driveability. All the dash lights will randomly come on for a few seconds while driving (as if the key is in position 2 with the engine off). Speedometer unaffected. I've had alternators fail in the past, and when that happens, just the battery light comes on. The alternator is charging the battery correctly and I have zero other issues other than the lights. It's super weird. Happens once or twice a day, sometimes more. FWIW, it started happening in the spring when everything thawed out and was super damp for a few months. I hope you find the problem; good luck.


All times are GMT -4. The time now is 04:41 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Unless otherwise noted, articles are property of 6thGenAccord.com and should not be used without permission. Website staff assumes no responsibility for user-posted content. By posting on 6thGenAccord.com, you agree to allow staff to reuse your material for promotional and other considerations. This site uses VigLink to automatically affiliate commercial links

» Featured Ride
CHECK OUT THIS WEEK'S FEATURED RIDE!



Powered by vBadvanced CMPS v3.2.3