Go Back   6th Gen Accord DIY and Performance Forums > The Garage > Engine & Transmission Mods

Engine & Transmission Mods Swaps, Turbo, Nitrous, bolt-ons, it all goes here

Register to remove these ads


Reply
 
Thread Tools Search this Thread
  #1  
Old 07-31-2018, 10:35 PM
Mastgohn Mastgohn is offline
Junior Member
Points: 5,840, Level: 22 Points: 5,840, Level: 22 Points: 5,840, Level: 22
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2013
Location: Dallas, Tx
Age: 25
Posts: 7
Rep Power: 0
Mastgohn is an unknown quantity at this point
H22 swapped 6th gen accord running rich

Hello, I have a 98 accord ex sedan (manual) that I recently swapped an h22a into. I rebuilt everything to stock specs and the internals are almost completely stock. The only difference was that I installed a set of pistons to bump the compression up to 11:1. I have followed the h22 swap thread that drift made almost to the letter. I even took the harness out and chased every wire.

Now here is my problem, the car runs very rich. I have installed an adjustable FPR and set it to stock specs and nothing has changed. The car reeks of fuel when running and it sounds cammed for some reason. I've tried everything I could think of, from stock injectors to all new ignition parts. I am running a 37820-p13-n50 ecu. Does anyone have any suggestions? Any help would be greatly appreciated.
Reply With Quote
  #2  
Old 08-02-2018, 12:18 AM
Nam1911a1's Avatar
Nam1911a1 Nam1911a1 is offline
Senior Member
Points: 4,028, Level: 18 Points: 4,028, Level: 18 Points: 4,028, Level: 18
Activity: 12% Activity: 12% Activity: 12%
 
Join Date: Aug 2016
Location: Southern Indiana
Age: 30
Posts: 405
Rep Power: 10
Nam1911a1 is an unknown quantity at this point
Re: H22 swapped 6th gen accord running rich

get it tuned
__________________
6th Gen Noob - Major tinkerer
Reply With Quote
  #3  
Old 08-03-2018, 06:29 PM
WHEEELMAN's Avatar
WHEEELMAN WHEEELMAN is offline
Senior Member
Points: 13,929, Level: 35 Points: 13,929, Level: 35 Points: 13,929, Level: 35
Activity: 25% Activity: 25% Activity: 25%
 
Join Date: Oct 2008
Location: Georgia
Age: 46
Posts: 773
Rep Power: 52
WHEEELMAN is more helpful than most
Member Photo Albums
Re: H22 swapped 6th gen accord running rich

Sounds cammed cause it runs pig rich, that is not good when driving/under load.


If you installed a FPR and had no effect, it's possible that means your injectors are just dumping fuel.

That ECU could have the P13 mod/chip which has modified fuel and ignition tables. So the ECU might be set to run a little richer now or just set in a way that it has one continuous flow - ALOT.

You would think that high compression would burn all of it, but....
with an FPR trying to adjust also, having no effect, something might need to be TUNED on the ECU/P13

I'm not familiar with those chips, so not sure if the Country Version matters either, they have 3 different ones.
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


» Featured Ride
CHECK OUT THIS WEEK'S FEATURED RIDE!



Powered by vBadvanced CMPS v3.2.3