Blinker won't work please help out

Kaden_se

New Member
Joined
Jul 7, 2016
Posts
1
Reaction score
0
Location
Simi Valley
I just put a new pair of headlights on my accord, and everything worked fine until this night, the blinker stopped working on the front right side. Both rear blinkers work and so does the front left one, but I have no idea why the blinker stopped working. I believe the bulb is ok because the light is on consistently, I just can't get it to flash. Putting in the new headlight involved splicing the wire that led up to the main light bulb, I think that has something to do with it, but it only now stopped working after a few days. Please help if you have any knowledge as to what to do. theyre Spec D Halo projector headlights if that helps. Thanks.
 

Sketch o5

Señor Greengo
Joined
Sep 6, 2005
Posts
25,429
Reaction score
127
Location
based in: not shared
there are two filaments in the front parking lights/turn signals because they're dual function...constant on when you turn them on and flashing for when you use the turn signal. i'd try replacing the bulb first before going too far into it. just take the bulb out of the side that works, and try it on the side that doesn't and that will tell you whether you need to dig any deeper than a new bulb.
 

RedRyder

Save the manuals
Joined
Sep 5, 2008
Posts
19,516
Reaction score
118
Location
Fawking, OH
It's possible for the dim lead to be intact while the bright lead is busted. Like Sketch said swap the bulbs and see what happens. Other things to check are your splicing connections and the brass contacts inside the connector to make sure they are making contact with the bulb leads.

Or, low blinker fluid.
 

GullyG00k

New Member
Joined
Jun 30, 2016
Posts
4
Reaction score
0
Location
US
If the blinker indicator on dash is solid for both, you have wrong bulbs for the blinkers.

Sent from my SM-G930T using Tapatalk
 
Back
Top