Blown Bulbs or Multiplex??

kem

Active Member
Joined
Oct 25, 2010
Posts
27
Reaction score
0
Location
new york
Hey 6GA. Couple months back i put in a Pioneer deck in my accord. I messed up by hooking up the illumination wire with i think a 12v and blew my dash and parking lights. Even that little dinging noise the the car makes when the lights are on went out. Couple days later i was checking the fuses and noticed either 10 or 13 was out (cant remember) i replaced it and only my parking lights came back on and some of my ac controls. I wanted to know if the multiplex unit was gone or maybe the bulbs in my cluster are out. Thanks!
 

henreeezy xp

Well-Known Member
Joined
Sep 16, 2007
Posts
4,801
Reaction score
5
Location
SoCal
is your instrument cluster lights out when headlights are on? if so, then yes its your multiplexer. and i have a DIY for that. lol
 

kem

Active Member
Joined
Oct 25, 2010
Posts
27
Reaction score
0
Location
new york
When the headlights are off only my warning lights like srs, brake, check engine , gear light and stuff are on. When i turn the parking and headlights on all those go out. The green glow is gone =/
 

redlinevtec

Well-Known Member
Joined
May 6, 2010
Posts
1,092
Reaction score
12
Location
South Orange County, SoCal
Yeah, sounds like your multiplexers. I have multiplexers for either an LX or EX. They are different, so you must get the ones that are the same as your car. PM me if interested.
 

hotaccord243

Well-Known Member
Joined
Sep 19, 2005
Posts
1,190
Reaction score
9
Location
SW suburbs, MN
I would agree sounds just like your multiplexors. Make sure you get the right one. Check local junkyards and forums for a used working one.....
 
Back
Top