ECU Pinout help!

hotdogmancandy

New Member
Joined
Jul 15, 2018
Posts
3
Reaction score
0
Location
Nashville tn
My stock f23a1 ecu (37820-PAA-L61) went out with code p1382 even after replacing the distributor starts and runs but stalls when warm... So i swapped for a f23a jdm ecu (37820-PGM-901). Car starts after moving pin a15(fuel pump relay) to a16 . Car now stays running when put in gear (automatic) but the speedometer doesnt work and the car wont shift. Any help with the wiring and ecu pinouts would be helpful .... thank you

Car is a 1998 honda accord sedan lx automatic with 260miles
 

BlkCurrantKord

Super Moderator
Joined
Sep 7, 2005
Posts
9,870
Reaction score
85
Location
Ohio
Did you fully check out the cause for the code? It's not unheard of for an ECU to fail but it's not exactly common either. I would put the pins back w/ the original ECU and retest all connections between the distributor, it's plug, and the ECU.
 

hotdogmancandy

New Member
Joined
Jul 15, 2018
Posts
3
Reaction score
0
Location
Nashville tn
thanks for the reply

yeah i measured the resistance at the distributor and at the plug for the ecu they all tested in range ... i think the ecu shorted out b/c i just did the head gasket and i mixed up some plugs - like iacv to tps and some others ( it was a stretch to get them plugged in wrong but did it :banghead:)
 

BlkCurrantKord

Super Moderator
Joined
Sep 7, 2005
Posts
9,870
Reaction score
85
Location
Ohio
That shouldn't short out an ECU though. Worst case the car won't run. You probably swapped TPS w/ the MAP sensor. They have the same connector.
 

hotdogmancandy

New Member
Joined
Jul 15, 2018
Posts
3
Reaction score
0
Location
Nashville tn
could the code p1382 mean my timings off a tooth or 2 or would it not run then ... thats the only code and it comes on as soon as it starts.
 

Latest posts

Back
Top