Idle Surging, Code P1259, please assist!

juicebox00

Well-Known Member
Joined
Aug 30, 2008
Posts
5,234
Reaction score
33
Location
SoCal
Hey guys, so I need some assistance with a close homies accord.

Short story, close friend bought NASOHC's accord when it came up for sale. Supposedly has a motor in it with a fresh rebuild and low miles, but unfortunately it has been giving him a fair amount of small issues here and there. Car is a 1998 F23a1 5spd

Car when into a trusted mechanics shop this weekend to repair a surging idle and p0108. The shop replaced the IACV with a new part.

About 80 miles after the shop release the car, and 2 separate start ups, the idle began to surge again and a new code popped up. P1259

Recent car care and replaced parts
-Fresh oil change
-New Vtec Solenoid
-New IACV
-AC installed and recharged



Idle surges pretty bad right now and we're trying to solve the issue asap and get rid of the P1259 code.

So far from a lot of online reading, the only thing I have found as a suggestion is to replace this part: http://www.amazon.com/gp/product/B001G7ODLS

Any help is greatly appreciated!!!!
 
Last edited:

Brimstone Brown

Well-Known Member
Joined
Jan 5, 2012
Posts
1,005
Reaction score
4
Location
Sac city ca
Did the runner down to the egr get cleaned when they replaced the iacv? Mine was completely clogged up when I had a similar issue.
 

001Stunna

Well-Known Member
Joined
Oct 21, 2008
Posts
3,203
Reaction score
81
Location
Toronto, ON CANADA
Tried resetting the code? Does it come back right away at key on, engine off? Does it come back at engine running rough in idle or only when you actually start driving it?

Before buying parts test the vtec switch/sensor first. Also im assuming there is no air leaks after changing out the IACV

Honda_Accord_LX_Sedan_L4_2254cc_2_3_L_SOHC_VTEC.jpg
 

juicebox00

Well-Known Member
Joined
Aug 30, 2008
Posts
5,234
Reaction score
33
Location
SoCal
Did the runner down to the egr get cleaned when they replaced the iacv? Mine was completely clogged up when I had a similar issue.

I'm not sure of that, but it's acting up now as it was before the iacv was replaced.


*UPDATE* Car has worsened and is surging a lot as well as small misfiring and sputtering with small spurts of black smoke. Under drive the car feels as if it has no power and is in limp mode.
 

juicebox00

Well-Known Member
Joined
Aug 30, 2008
Posts
5,234
Reaction score
33
Location
SoCal
Tried resetting the code? Does it come back right away at key on, engine off? Does it come back at engine running rough in idle or only when you actually start driving it?

Before buying parts test the vtec switch/sensor first. Also im assuming there is no air leaks after changing out the IACV

We reset the code and the car was still surging. It doesn't come back on right away with the key in, but it does after a little bit of driving. It's currently back to square 1 as in how it's acting.
 

Latest posts

Back
Top