Multiplex Control unit. No Light on Instrument Cluster Gauges

V6DZ

New Member
Joined
Apr 26, 2024
Posts
3
Reaction score
0
Location
Central Washington
2000 Honda accord v6
Instrument cluster has never worked. Well The lights for the gauges have never worked. but the Lights for the warning lights, blinkers and all those work just fine.


After doing research im finding multiplex control unit being the culprit. I have tore the cluster out, checked and changed all bulbs. Outside of the vehicle i can jump the cluster gauges lights and they work. Ive checked the #9 fuse. Were all good there.

There is a recall on these multiplexes i guess. See below link.


"CORRECTIVE ACTIONReplace the driver’s side multiplex control unit.PARTS INFORMATIONMultiplex Control Unit (4-door models):p/N 38800-S84-A06, H/C 6254676Multiplex Control Unit (2-door models):p/N 38800-S82-A03, H/C 6218911"

Now we Broke boys. My question is, is there a way to open this multiplex and fix it? or do we need to just get a new one? Thanks!

Ebay link to multiplex
 

Attachments

  • Cluster5.jpg
    Cluster5.jpg
    50.9 KB · Views: 0
  • 2009-07-05_151901_GaugeBulbs99AccordEX01a.jpg
    2009-07-05_151901_GaugeBulbs99AccordEX01a.jpg
    81.3 KB · Views: 0
  • images.png
    images.png
    12.9 KB · Views: 0
  • s-l1600.jpg
    s-l1600.jpg
    175.6 KB · Views: 0

RedRyder

Save the manuals
Joined
Sep 5, 2008
Posts
19,521
Reaction score
123
Location
Fawking, OH
I don't recall anyone disassembling their multiplexor to fix it, but it has been a while. Still, I am thinking it requires replacement.
 
Back
Top