my cluster is trippin!!!!???

Kasta

New Member
Joined
Apr 27, 2010
Posts
2
Reaction score
0
Location
514
from time to time my cluster will go crazy on me, randomly the washer fluid light will light up, then my speedo needle goes to 0km/h (even when im rollin) and my engine temp needle drops down all the way even tho its actually at a good temp FML anyone ever had this problem b4???

possible bad ground? cluster is busted????
 

MrLazie1

Well-Known Member
Joined
Nov 11, 2008
Posts
2,171
Reaction score
3
Location
LA to SGV
have you change anything to it? like the gauge faces or wiring? or did you just get the car like that?
 

Kasta

New Member
Joined
Apr 27, 2010
Posts
2
Reaction score
0
Location
514
i bought the car off my father who bought it brand new from the dealer in 2000, i havent modified anything in the cluster(wiring or faceplates) this problem has been going on for about 2 yrs lol, it doesnt really bother me but when im drivin i dont really know how fast im going lol i just follow the speed of traffic :p
 

SykVSyx

Well-Known Member
Joined
Jan 6, 2007
Posts
13,940
Reaction score
30
Location
Tee Dot Ohh
check your connections

This. Is. Accurate.

Speaking of which, my car has been acting up on me as well lately, all of a sudden, only my driver's window will work from the power window controls on the driver's door(the other windows work individually from each door). My trip clock keeps going back to 0.0 every time I start the car. I can't lock/unlock all the doors unless the car is running. Very frustrating/annoying.
 

barry77

Member
Joined
Nov 22, 2008
Posts
8
Reaction score
0
Location
virginia
Cluster lights dont come on. Fuses are good. anyone knows which is the relay and location. This happened after installing my dvd player.
 
Last edited:

meximan16

Well-Known Member
Joined
Jul 22, 2009
Posts
1,395
Reaction score
1
Location
SLC!!!
are any of ur interior lights on? brake lights, parking lights working?
 

Latest posts

Back
Top