P0131 trouble code, rough RPM - with video

Discussion in 'URGENT - Help Quick!' started by Avas Eduard, Aug 13, 2021.

  1. Avas Eduard

    Avas Eduard New Member

    Posts:
    1
    Likes Received:
    0
    Joined:
    Aug 13, 2021
    Location:
    RO
    Hi there!

    Few weeks ago my dash showed the engine check light, so I went to a mechanic and he read the P0131 code on the OBD, which is "O2 Sensor Circuit Low Voltage Bank 1 Sensor 1" so he went ahead and replaced the ""faulty" sensor with a DENSO O2 sensor and erased the error. Two minutes later, the error showed up again :favorites68:

    Made some more attempts of erasing the code hoping it won't show up again, but it showed up every time in a few seconds up to a few minutes.

    I don't notice anything wrong while driving, I have power, VTEC works, no smoke, no weird sound, etc.
    The only thing that I noticed is that the car has a rough idle, it keeps oscillating a bit up or down and after I press the gas pedal, the RPM drops way lower than it should and then goes back up again to its normal value.It drops so low that it nearly kills the engine, but never killed it though.

    I've made a short video here with several situations:

    Any ideas what else could be now that I have a brand new O2 sensor? What should we look for?

    Thanks in advance!

    PS. The car is a 2002 6th gen Honda Accord Coupe, 2.0i VTEC, manual gearbox, with under 60000 miles in great overall condition, no engine issues before, everything stock.
     
  2. INK DEMON

    INK DEMON Well-Known Member

    Posts:
    74
    Likes Received:
    8
    Joined:
    Nov 29, 2008
    Location:
    SAN DIEGO
    Check the fuel pressure. It should read between 38-46 psi and 47-54 psi with the fuel pressure regulator hose disconnected and clamped.

    Do you have a K20 swapped engine in your car?
     

Share This Page