Derek's 2002 Coupe EX (5MT)

Discussion in 'Members Rides' started by phi1542, Mar 13, 2016.

  1. phi1542

    phi1542 Well-Known Member

    Posts:
    714
    Likes Received:
    1
    Joined:
    Feb 5, 2013
    Location:
    Sacramento, California
    Re: phi1542's 02 Coupe 5-Speed

    FML..........

    Sent from my SAMSUNG-SM-G925A using Tapatalk
     
  2. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
  3. BlkCurrantKord

    BlkCurrantKord Super Moderator

    Posts:
    9,313
    Likes Received:
    41
    Joined:
    Sep 7, 2005
    Location:
    Ohio
    Re: phi1542's 02 Coupe 5-Speed

    You should be able to buy the fittings separately from where you got the parts. Summit racing also sells them if you know the fitting size.
     
  4. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    Last edited: Sep 21, 2016
  5. phi1542

    phi1542 Well-Known Member

    Posts:
    714
    Likes Received:
    1
    Joined:
    Feb 5, 2013
    Location:
    Sacramento, California
    Re: phi1542's 02 Coupe 5-Speed

    Oh sweet thanks guys! I'll give them a call to see which one is the right one to get. I'm getting an alignment right now since I took the suspension apart. They do a suspension inspection so I'll see what else is up that could be making noise.

    Sent from my SAMSUNG-SM-G925A using Tapatalk
     
  6. phi1542

    phi1542 Well-Known Member

    Posts:
    714
    Likes Received:
    1
    Joined:
    Feb 5, 2013
    Location:
    Sacramento, California
    Re: phi1542's 02 Coupe 5-Speed

    I wasn't able to get the alignment done. They said the driver side is a quarter inch lower than the passenger in the fronts so they said I should adjust that first before they align the car. They also suggested me getting upper camber adjustment rods. Assuming they are talking about adjustable upper control arm in the rear. Do I really need it?

    As for the noise they told me the RSB link rubs on the strut so that is what most likely to be causing the noise. They still charged me 30 bucks for that....

    Sent from my SAMSUNG-SM-G925A using Tapatalk
     
  7. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    Re: phi1542's 02 Coupe 5-Speed

    You said you have 2 fingergaps, right? You don't need a camber kit.

    On which side is the strut being rubbed by the endlink? Take a look and see if you can see scrape marks where those two parts are coming in contact. Is your RSB off center?
     
  8. phi1542

    phi1542 Well-Known Member

    Posts:
    714
    Likes Received:
    1
    Joined:
    Feb 5, 2013
    Location:
    Sacramento, California
    Re: phi1542's 02 Coupe 5-Speed

    Yeah in the front. I can barley stick 2 fingers in the rears but it's approximately. No matter how much I raise the rear it's hard to get it to match the front without it being too high in the back lol is it OK if not all 4 are exact same height? I measured all 4 the same but when I measure it fender to ground it's not all the same. One side is lower than the other so I think it might just be the ground. Another reason why the shop didn't do the alignment was because he said the front left is quarter inch lower than the front right. I measure both sides the same and it's a 3 inch gap on both so I don't know why he said one side is lower than the other.

    Turns out that the grease fittings are already on the links lol..... I'm dumb. But I'm pretty sure this is where it rubs. Super close but when I hit bumps I hear the nose so it probably rubs then. How do I fix it?

    [​IMG]

    [​IMG]

    I also saw this but the technician didn't say anything about the exhaust hanger rubbing

    [​IMG]

    Sent from my SAMSUNG-SM-G925A using Tapatalk
     
  9. 604ACCORD

    604ACCORD Well-Known Member

    Posts:
    601
    Likes Received:
    5
    Joined:
    Feb 6, 2014
    Location:
    Vancouver BC
    Re: phi1542's 02 Coupe 5-Speed

    Good old 02 tls rsb I had same issue if u go to newer Gen rsb you won't have this issue. Thats really weird almost looks like those coils won't work with moog endlinks man. There is no way to adjust that unless u go to oem end links
     
  10. phi1542

    phi1542 Well-Known Member

    Posts:
    714
    Likes Received:
    1
    Joined:
    Feb 5, 2013
    Location:
    Sacramento, California
    Re: phi1542's 02 Coupe 5-Speed

    Yeah I have the 3rd gen TL Progress 24mm sway bar. Seriously??? Is the OEM ones smaller? Wouldn't all coils be the same though since they're all relatively the same size and stuff? I had the same noise with my other coils thats why I thought the rear struts were blown but its just these end links. What's the difference with MOOG anyways? I only got them because everyone else got them LOL
     

Share This Page