RR's '99 coupe EX-L

Discussion in 'Members Rides' started by RedRyder, Jan 31, 2009.

  1. phi1542

    phi1542 Well-Known Member

    Posts:
    714
    Likes Received:
    1
    Joined:
    Feb 5, 2013
    Location:
    Sacramento, California
    Damn those look good. No more VS-XX?

    Sent from my SAMSUNG-SM-G925A using Tapatalk
     
  2. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    Thanks. Winter wheels ;)
     
  3. 604ACCORD

    604ACCORD Well-Known Member

    Posts:
    601
    Likes Received:
    5
    Joined:
    Feb 6, 2014
    Location:
    Vancouver BC
    Looks good man, love the winter setup..
     
  4. Varnell

    Varnell Well-Known Member

    Posts:
    1,102
    Likes Received:
    4
    Joined:
    Mar 16, 2013
    Location:
    Charlotte, NC
    Clean as ever. Strange seeing it without the Works.

    Wasn't it your car that went through the bird version of D-Day a year or two ago?
     
  5. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    Thank you. Yea I miss the fitment of the Works but not cleaning them.

    Haha yes it was the victim of a vicious hate crime. Neverforget. :lawl:
     
  6. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    Rotora BBK finally let go, rotors cracked clean through. They had a good run, bought the kit used in 2010. Factory front brakes are back on now, car lost a little flair sadly.

    [​IMG]20180906_175301 by C B, on Flickr


    Sucks because the calipers are still good, and pads are still available I think. It's the rotor that is the problem, I have searched high and low for a solution but nothing has materialized. I might try spacing them since they are 2pc and see if the 350Z rotors people are using with the RL Brembo's might work. But for now, stuck with these nice paperweights.


    [​IMG]20180908_132147 by C B, on Flickr\


    Otherwise this car is still going strong at 209k miles. Recharged the A/C recently and one of the front sway endlinks broke so I have some Moogs to replace them with. Climate control unit is faulty I think, sometimes I can only get cool or hot air depending on its mood. Swap is still fun and problem free at 117k miles. Clearcoat failure is happening in a few areas, wish I had money sitting around to get the body restored fully.
     
    Last edited: Oct 24, 2018
  7. puzzlemaster94

    puzzlemaster94 6GA Connoisseur

    Age:
    25
    Posts:
    1,481
    Likes Received:
    5
    Joined:
    Jun 6, 2012
    Location:
    Louisville Area
    Sad to hear about the BBK, but 8 years out of a used kit is not bad lol. As for the climate control controls, I have a spare 01-02, since I believe you swapped to 01-02. If you didnt, I have 98-00 ones too. If you want one, text me.
     
  8. RedRyder

    RedRyder Be a better driver

    Posts:
    19,213
    Likes Received:
    65
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    ^Might take you up on the 01-02. Trying to remember if I can just plug in the 98-00 to make sure that is actually the problem.
     
  9. puzzlemaster94

    puzzlemaster94 6GA Connoisseur

    Age:
    25
    Posts:
    1,481
    Likes Received:
    5
    Joined:
    Jun 6, 2012
    Location:
    Louisville Area
    If you didn't cut the plug, I don't see why you couldn't
     
  10. cg4ever

    cg4ever Well-Known Member

    Posts:
    95
    Likes Received:
    4
    Joined:
    Sep 5, 2018
    Location:
    Europe

    is the switch always stay lit up even if your headlights are off ? Because our 6th gen didn't came with a illuminated switch so my guess is that our harness don't have that extra wire that make the switch lit up when turning on the headlights, i'm wrong ?
     

Share This Page