RR's '99 coupe EX-L

Discussion in 'Members Rides' started by RedRyder, Jan 31, 2009.

  1. RedRyder

    RedRyder Be a better driver

    Posts:
    19,202
    Likes Received:
    64
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    ^Yes the switch is only lit up when I flip on the parking lights or headlights. If the switch is in the OFF position then AUTO does not light up. USDM 98-00 window switch did not light up, but 01-02 did light up.
     
  2. cg4ever

    cg4ever Well-Known Member

    Posts:
    82
    Likes Received:
    1
    Joined:
    Sep 5, 2018
    Location:
    Europe
    Wait, 6th gen 98-02 didn't had any lit up switch so here you're talking about the 01-02 acura button switch right ?

    So you just replace the whole master switch in a plug'n play fashion and it still lit up and turn off when you flip your park or head lights ?

    Not sure exactly how it works but what make the switch recognize that you flip the park or headlights to make the switch lit up ? It comes from the switch module itself or there is an extra wire in the harness in those Acura ?
     
  3. RedRyder

    RedRyder Be a better driver

    Posts:
    19,202
    Likes Received:
    64
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    ^Ok I checked and I was wrong sorry, the AUTO is lit up on the window switch regardless of headlight stalk position. If parking lights/headlights are off, AUTO is still illuminated. So basically it's on all the time.

    My window switchgear is from the 01-02 Accord. 98-00 window switch did not light up (AUTO was printed), 01-02 does light up. I changed my 98-00 woodgrain to the 01-02 silver trim, and since I pulled it all from a junkyard I got the 01-02 switchgear too, but I remember I had to do a sort of hybrid using both 98-00 and 01-02 switchgear to get it all to fit and work properly.
     
  4. cg4ever

    cg4ever Well-Known Member

    Posts:
    82
    Likes Received:
    1
    Joined:
    Sep 5, 2018
    Location:
    Europe
    As i guessed, there should be an extra wire to the Acura harness that indicate the switch when the park or headlights are flipped on or off.

    From what i noticed the RL and the 6th gen have the same harness connector with 12 small pins in the middle and 8 larger pins by 4 on each sides. Also both modules have the same size even if the 6th gen doesn't have the extra rear windows switches.

    Another note, the RL module doesn't have the 2 pin on the back for the window lock button like our 6th gen, i think they moved the connection to the harness itself because there where no place because of the bulb, yes the ON is illuminated ! Since both RL and 6th gen share the same type of connector and number of pins, i won't be surprised if two wires goes in the same pin on the Acura harness but if someone is reading this and could verify the RL harness it will be helpful for sure. In this case we could re-pin the 6th gen wires into the right pin connector harness.

    So i'm thinking i'll try to use an edm Honda Legend ( same as RL ) window master switch and remove the 2 rear windows switch. Then i'll place the PCB and everything in the 6th gen box module. They are basically the same but some slight modifications may be enventually made for a perfect fit.

    Overall i think it should work, the only thing i can't see how to make it work is to lit up the switches accordingly with the park or headlights turner on. I'm sure there is an extra wire that goes from the window switche harness but don't know where it hook up to get the signal. If someone have an idea please feel free to share any though.

    On another note, i also bought an '02 illuminated TL mirror switch with the harness on it because i notice it's different from the 6th gen harness. Some re-pin incoming.. Any idea where i could found the 98-00 6th gen and 02 TL pins diagram ?

    I'm also planning to get the passenger side illuminated switch from the edm Honda Legend ( again same as RL ) with it's harness because different from the 6th gen. Five pins for the Legend ( RL ) and four for the 6th gen. My guess is that the extra pin is for the on/off illumination when using park/headlights but to be confirmed..
     
    Last edited: Jan 10, 2019
  5. cg4ever

    cg4ever Well-Known Member

    Posts:
    82
    Likes Received:
    1
    Joined:
    Sep 5, 2018
    Location:
    Europe
    Finally purchased an CL master switch. Both driver and passenger window buttons are illuminated. I'm not sure but i even think the window lock button is, i'll see when i get this in hand.

    I prefer the CL translucent Auto and small dot light passenger window than the RL Auto "glass" type and wide light passenger window button. Now i'm looking to get the CL passenger side window switch as well.

    My guess is that the CL switches might also have a green puke lit. I'd like to switch them to the original 6th gen light green. Did you tried to change your switch bulb color or you still have the original one ?
     
    Last edited: Jan 11, 2019
  6. RedRyder

    RedRyder Be a better driver

    Posts:
    19,202
    Likes Received:
    64
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    ^I have wanted to change the bulb color in the auto button but never got around to it. Same with my heated seat buttons.
     
  7. cg4ever

    cg4ever Well-Known Member

    Posts:
    82
    Likes Received:
    1
    Joined:
    Sep 5, 2018
    Location:
    Europe
    Where in the process you stucked ? is the bulb on the pcb or inside the switche ?
     
  8. RedRyder

    RedRyder Be a better driver

    Posts:
    19,202
    Likes Received:
    64
    Joined:
    Sep 5, 2008
    Location:
    Fawking, OH
    ^I never looked. The MIRROR text on my PFM switch also looks translucent like it should light up, and there are other PFM switches that are the same but the MIRROR text is clearly printed on the plastic...but it never has and I've never opened it to look for a bulb. FNCONE said he he looked at his PFM switch (he has the same as me) and he couldn't find a bulb, so maybe there isn't one. Anyway that's a separate issue lol.
     
  9. cg4ever

    cg4ever Well-Known Member

    Posts:
    82
    Likes Received:
    1
    Joined:
    Sep 5, 2018
    Location:
    Europe
    So your MIRROR inscription doesn't lit up ? You had to re-pin your Mirror switch or just used the harness that came with the mirrors ? because it's not the same harness as our 6th gen from what i've seen. You couldn't found a way to make the illumination work or you didn't really bother to make it work ?
     
    Last edited: Jan 11, 2019
  10. cg4ever

    cg4ever Well-Known Member

    Posts:
    82
    Likes Received:
    1
    Joined:
    Sep 5, 2018
    Location:
    Europe
    Hello RedRyder,

    Since i can't start a conversation could you send me an PM please ? I have to ask you something if you don't mind. Thanks
     
    Last edited by a moderator: Jan 18, 2019 at 11:22 AM

Share This Page